Franz Holzinger

Verse of the day

Lieblich und schön sein ist nichts; ein Weib, das den HERRN fürchtet, soll man loben.
Sprueche 31:30

© Bible Gateway's Verse of the Day


Autor  
30-08-19 14:45:27 tt_products 2.8.21 unter PHP 7.2
André S.
Hallo Herr Holzinger,

ich versuche tt_products 2.8.21 unter PHP 7.2 zum laufen zu bringen und habe entsprechend alle relevanten Extensions (tsparser, table, div2007) zunächst auf die neueste Version unter TYPO 7.6 aktualisiert.

Im Frontend kommt nun folgende Meldung:

PHP Warning: Use of undefined constant ADDONS_TT_PRODUCTS_EXT - assumed 'ADDONS_TT_PRODUCTS_EXT' (this will throw an Error in a future version of PHP) in /Users/sheydin/Sites/pellens-verlag/typo3conf/ext/tt_products/marker/class.tx_ttproducts_marker.php line 151

Ist diese tt_products Version etwa nicht PHP 7.2 tauglich? Falls doch, wie bekomme ich diese Warnung weg?

Danke!
30-08-19 19:20:41 tt_products 2.8.24
Franz Holzinger
Siehe extensions.typo3.org.
Für PHP 7.2 muss die Version 2.8.24 verwendet werden.

Grundsätzlich aber sollte nun ein Update auf tt_products 2.9.5 und am besten auf die aktuelle Version vom Github gemacht werden.

https://github.com/franzholz/tt_products/

Für tt_products 2.8.x werden nur noch schwerwiegende Fehler behoben. PHP 7.2 wird noch unterstützt.
30-08-19 19:25:57 Korrektur in Datei ext_localconf.php
Franz Holzinger
Für nicht definierte Konstanten kann man dieses in die Datei ext_localconf.php von tt_products einfügen:


if (!defined ('ADDONS_TT_PRODUCTS_EXT')) {
define('ADDONS_TT_PRODUCTS_EXT', 'addons_tt_products');
}

17-12-19 17:04:47 PHP 7.3
Franz Holzinger
tt_products läuft inzwischen auch unter PHP 7.3.
< Zurück zum Forum