Franz Holzinger

Verse of the day

Ich bin der gute Hirte und erkenne die Meinen und bin bekannt den Meinen, wie mich mein Vater kennt und ich kenne den Vater. Und ich lasse mein Leben für die Schafe.
Johannes 10:14-15

© Bible Gateway's Verse of the Day


Buch: Der TYPO3 Webshop
 
 
Neue Probleme
 
autor: Michael Schulte Datum: 11-04-15 14:14:23
 
Hallo Herr Holzinger,

ich habe das komplette System noch einmal neu aufgesetzt.

Nun treten nach den Steps im Kapitel 1 des Buchs neue Fehler auf :

1. Wenn ich die Einzelansicht aufrufen möchte erhalte ich folgende Fehlermeldung "Products: Wrong parameters. GET/POST var 'tt_products[product]' is missing or no item with uid = 1 found on allowed pages (6,) ."
Wo liegt denn da das Problem ?
Ich habe alles so gemacht, wie beschrieben. Und das ist ja mittlerweile nicht das erste Mal, daß ich die Schritte ausführe. So langsam kenne ich die asuwendig.

2. Dann habe ich die Seiten für den Warenkorb auch eingefügt.
Ich kann den Warenkorb aufrufen (was vorher auch schon ging).
Bis zur Neuinstallation wird kein Kommentar angezigt.
Jetzt wird mir angezeigt, daß der Warenkorb noch leer ist.
dies wird auch angezeigt, wenn ich vorher den Testartikel auf der Listenansicht in den Warenkorb lege.
ISt das in dem Stadium der Konfig ok oder müßte der Artikel angezeigt werden ?

Ich bin bezüglich der Beschreibung etwas irritiert.
Folgende Formulierung wird bei allen Seiten benutzt "Weisen Sie als Ausgangspunkt den SysOrdner mit Ihren Produkten zu".
Inhaltlich ist mir schon kalr, daß ich auf die Produkte zugreifen muß, wenn ich diese auch anzeigen möchte.
Mir stellt sich die Frage, wo genau dieser Ausgangspunkt zu finden ist. Gehe ich recht in der Annahme, daß es im Reiter Behaviour (wenn ich den Seiteninhalt editiere, z.B. Edit Page Content on page "Shop") unter Record Storage Page zu finden ist.

Schon einmal vielen Dank für die Hilfe.

Viele Grüße

Michael Schulte