Franz Holzinger

autor  
8-10-14 18:24:12 mbi_products_categories
Konrad Mauermann
Hallo,
ich habe das Problem das es nicht funktioniert bei mir, mit der Typo3 V6.1. oder V6.2.x. Ich bekomme folgende Fehlermeldung wenn ich es installiere:

Fatal error: require_once() [function.require]: Failed opening required 'PATH_t3libclass.t3lib_treeview.php' (include_path='/home/www/p239957/html/typo3/typo3/contrib/pear/:.:/usr/local/php/lib/php:/usr/local/php/lib/php/PEAR') in /html/typo3/typo3conf/ext/mbi_products_categories/lib/class.tx_mbiproductscategories_tcefunc_selecttreeview.php on line 49

Mach ich da was falsch, gibt es eine alternative dafür oder ist da ein update geplant?
Würde mich über hilfe bei diesen Problem mich sehr freuen

mfg
Konrad Mauermann
9-10-14 15:16:52 Änderung in TYPO3 6.1 und 6.2
Franz Holzinger
Mit TYPO3 6.1 und 6.2 hat sich einiges geändert. Es gibt die Datei "class.t3lib_treeview.php" nicht mehr. Sie ist verschoben worden und hat einen anderen Namen. Das ist die Basis für den Baum von mbi_products_categories.

Ich habe alle nötigen Änderungen, die für TYPO3 6.1 und 6.2 notwendig sind, in die erweiterte Version von mbi_products_categories eingebracht. Sie ist hier erhältlich:

http://ttproducts.de/tt_products_ext.html?&tt_products[product]=3

Ich entwickle die ältere Version von mbi_products_categories aus dem TER nicht mehr weiter. Denn die Änderungen am PHP Code, die mit TYPO3 notwendig werden, erscheinen mir als zu umfangreich, um sie noch in die alte Ausgabe von mbi_products_categories einzubauen. Der Aufwand erhöht sich vor allem deshalb, weil es unter mehreren Versionen von TYPO3 und PHP gleichzeitig lauffähig sein muss.
< BACK TO FORUM