Franz Holzinger

Verse of the day

Es ist das Herz ein trotzig und verzagtes Ding; wer kann es ergründen? Ich, der HERR, kann das Herz ergründen und die Nieren prüfen und gebe einem jeglichen nach seinem Tun, nach den Früchten seiner Werke.
Jeremia 17:9-10

© Bible Gateway's Verse of the Day

29-12-12 19:38:56 tt_products 2.7.4 and typo3 4.6.15 no products shown in FE
Eva Benito
Dear Mr. Holzinger, dear forum members,

My name is Eva Benito, I am quite a newbie to typo3 and to tt_products, but I've been doing quite a bit of reading and playing around and I came across a problem that seems to appear quite often in relation with tt_products. To summarize, after successful installation of typo3 4.6.15, tt_products 2.7.4 and all dependencies and after following the instructions in the manual and the Webshop book rigurously, I still cannot get the products I enter in the BE to show in the FE. Let me tell you what I've tried and perhaps you can tell me what I may be missing/doing wrong:

Firstly let me tell you that I am using a unix sytem (macOS 10.5.8), a local server set up with MAMP, php 5.3.5, typo3 4.6.15, and tt_products 2.7.4 (downloaded through the extension manager) just to have all the specs out there. So, here is what I did:

After installing typo3 and tt_products and dependencies, I generated a new page and a system folder under this page. In the latter I put a couple of test products (both products and articles) and in the former I used a standard built-in template (the green one in particular) and included under "include the basis template" the tt_products extension template, where I made sure to include the static template Shop System Old Style.
In this page I added content, namely the shop-system plugin and specified Products:List. I made sure to specify the system folder as the "Record Storage Page" for the plugin to look for products and I set recursive to infinite. I also checked the tt_products extension template under constants and made sure that the PID for list item coinced with the PID of the "start page" where I meant my products to appear. Unfortunately, I still can only see the page with the basic design of the default template and no products are shown.
Now, I tried a couple of things here: I can add regular content (i.e., text and images for instance) and this does translate into the FE. I tried switching on the php error display (changed in the displayErrors setting to 1) but it does not show any error (which seemed unsual, the page just looked absolutely normal, maybe I am missing something here? Should I see some sort of php message/log in the top of the page or just in case there is an error?).
Reading around the net and this forum it seemed to me that the most common error is forgetting to include the static template Shop System Old Style, but this I did under the tt_products extension template. I also tried just including the static template in the regular template directly instead of doing it through the inclusion of the basis template, but also to no avail. I tried different typo3 versions (4.7.7 and 4.5.) but with none did I succeed.
So I am absolutely clueless as to what else to try, so if someone has encountered such a situation before and has some feedback to offer or if you notice any errors in my approach, I would be extremely grateful for your input.

Thanks a lot in advance.

With best regards,

3-01-13 17:11:26 use pid_list instead of starting point
Franz Holzinger
Hello Eva.

The following things you should do differently:

1.) Do not include the 'Shop System Old Style' static template. This is deprecated. But you must include the 'Shop System CSS Styled' template instead of it.

2.) Do not use the Starting Points or the Record Storage PIDs in the shop plugins for the beginning. This is only reserved for experts. Instead you set the pid_list constants or setup to the root page of your shop. This will ensure that the shop will find all products and categories in all languages.

3.) Do never clear the default setup of tt_products.
A line sequence like
plugin.tt_products >
plugin.tt_products = USER
plugin.tt_products {
is strictly forbidden in your setup.

You will see any errors only in the PHP error log file. Or you can turn on the displayErrors in the TYPO3 install tool and set it to 1.
tt_products 2.7.4 runs up to TYPO3 4.7.99. Make sure you have installed the latest versions of the extensions div2007 and table.

Check the HTML source of the page where the shop plugin should appear in the FE. You should see some HTML comments about tt_products there.
< Zurück zum Forum