Franz Holzinger

Verse of the day

Wer sich aber rühmt, der rühme sich des HERRN. Denn darum ist einer nicht tüchtig, daß er sich selbst lobt, sondern daß ihn der HERR lobt.
2 Korinther 10:17-18

© Bible Gateway's Verse of the Day


autor  
28-01-16 16:15:59 Preis2 Feld verschwunden in 2.8.2/2.8.3
André Sheydin
Leider ist das Feld Preis2 aus dem Backend Maske verschwunden. Über die Listenansicht ist es auch nicht aufrufbar.
29-01-16 14:56:33 compatibility6
Franz Holzinger
Für tt_products 2.8.3 muss die Extension compatibility6 installiert werden. TYPO3 7.6.2 kann sonst scheinbar die 2. Options Palette nicht anzeigen.
29-01-16 15:26:22 Rückfrage
André Sheydin
Das ist eigentlich das einzige Problem, das compatibility6 erfordert. Ist es denn geplant diese Abhängigkeit loszuwerden? Oder ist es vielleicht sogar in den neueren bezahlten Versionen der Fall? Diese Extension verursacht nämlich Schwierigkeiten an anderen Stellen.
29-01-16 15:43:07 tt_products 2.12.0
Franz Holzinger
In tt_products 2.12.0 gibt es keine Abhängigkeit von compatibility6.

Man kann es in tt_products 2.8.1 umgehen, indem man die Datei tca.php ändert und die Felder der Paletten nach oben in die Zeile hinter 'types' hineinschreibt.

'types' => Array (
'0' => Array('showitem' => 'title;;5;;3-3-3, itemnumber;;2, category, address, price;;3,graduated_price_uid,offer;;4;;3-3-3,weight;;6,hidden;;1,' .
'--

'palettes' => Array (
'1' => Array('showitem' => 'sellstarttime,sellendtime,starttime,endtime,fe_group'),
'2' => Array('showitem' => 'inStock,basketminquantity,ean'),

Die unteren Feldbezeichnungen einfach oben dazuschreiben.

In einigen Monaten werde ich eine Umstellung für tt_products 2.8.x machen. Bis dahin muss entweder compatibility6 installiert werden oder die tca.php überarbeitet werden.
29-01-16 15:49:24 Danke!
André Sheydin
Ich habe jetzt einfach nur price2 hinter price im types-Array eingefügt.
6-02-17 11:08:21 compatibility6 nicht mehr notwendig
Franz Holzinger
In allen neueren tt_products Versionen (ab 2.7.x) wird keine compatibility6 Extension benötigt. Alles für die Kompatibilität Notwendige wird bereits durch die Extension div2007 getan. Es wird empfohlen, keine compatibility6 zu installieren.
< Zurück zum Forum