Franz Holzinger

Verse of the day

Lasset kein faul Geschwätz aus eurem Munde gehen, sondern was nützlich zur Besserung ist, wo es not tut, daß es holdselig sei zu hören.
Epheser 4:29

© Bible Gateway's Verse of the Day


Autor  
10-11-10 10:01:21 Rabatt nur erste Zeile
David Farkas
Hallo,

ich hoffe jemand kann mir helfen. Ich kämpfe schon seit Wochen mit dem Rabatt in tt_products. Jetzt habe ich um den Shop endlich online zu bringen, den Rabatt pauschal auf 20% geändert (Einführungsrabatt).
plugin.tt_products.getDiscountPrice = 1
plugin.tt_products {
discountprice.10 {
type = price
prod.type = percent
prod.0 = 20
}
}

In der ersten Zeile wird der Rabatt auch richtig angezeigt. Für die weiteren Positionen wird allerdings kein Rabatt angezeigt und auch nicht berechnet. Woran könnte das liegen?

Version: 2.9.1

Vielen Dank

David
12-11-10 10:57:49 Manuell gehts
David Farkas
Ich habe gerade gemerkt, dass es nur dann funktioniert wenn ich dem FE_USER manuell den Rabatt zuweise.
Warum ist das so? Was mache ich falsch?
13-11-10 16:57:42 Rabatt
Franz Holzinger
Der Rabatt, der beim FE Benutzer eingetragen wird, ist unabhängig vom Rabatt aus discountprice.

Wird der Rabatt bereits angezeigt?

Es muss entweder discountGroupName eingetragen sein oder getDiscountPrice = 1.
13-11-10 18:03:51 Nur die erste Zeile
David Farkas
Rabatt wird in der ersten Zeile angezeigt und auch berechnet. Auch beim Gesamtrabatt ist nur die erste Zeile in die Berechnung aufgenommen worden.

plugin.tt_products.getDiscountPrice = 1 (siehe erster Beitrag)

plugin.tt_products.discountGroupName auch, allerdings hätte ich den Rabatt gerne auch für nicht angemeldete Benutzer. Ich lasse nämlich die Anmeldung über sr_feuser_register laufen, da ich bei der Bestellung über tt_products nicht die Möglichkeit habe (oder noch nicht weiß wie) die Emailadresse zu verifizieren.
17-11-10 16:33:45 Korrektur
Franz Holzinger
Der Fehler ist jetzt behoben. Ich habe eine neue tt_products 2.9.1 erstellt.
17-11-10 16:49:38 Vielen Dank
David Farkas
Super! Vielen Dank! Nach einem kurzen Test funktioniert alles wie gewünscht!
< Zurück zum Forum