Franz Holzinger

Verse of the day

Es wird aber des HERRN Tag kommen wie ein Dieb in der Nacht, an welchem die Himmel zergehen werden mit großem Krachen; die Elemente aber werden vor Hitze schmelzen, und die Erde und die Werke, die darauf sind, werden verbrennen. So nun das alles soll zergehen, wie sollt ihr denn geschickt sein mit heiligem Wandel und gottseligem Wesen,
2 Petrus 3:10-11

© Bible Gateway's Verse of the Day


Autor  
12-10-11 11:29:35 Problem mit ###ARTICLE_NOTE###
Florian Schweitzer
Moin Moin,

ich habe ein Problem mit dem Marker ###ARTICLE_NOTE###.

Wenn ich auf die Single-Ansicht eines Produkts mit Artikeln gehe, bleibt dieser leer.
Erst nach Auswahl einer Variante wird der entsprechende Text angezeigt.

Alle anderen Marker ###ARTICLE_TITLE###, ###ARTICLE_ITEMNUMBER### etc. sind sofort gefüllt (mit den Daten der ersten Variante).

Version ist die 2.7.2...
19-10-11 12:08:57 tt_products 2.7.3
Franz Holzinger
Ich kann dieses Problem mit tt_products 2.7.3 nicht nachvollziehen.
Der Marker ###ARTICLE_NOTE### wird auch in der Produkt Einzelansicht korrekt ersetzt.

17-09-14 10:32:13 Gleiches Problem
Sebastian Klein
Hallo, ich habe das gleiche Problem.

Technisches:
- TYPO3 6.2.2
- tt_products 2.7.11
- taxajax 0.2.12
- useArticles = 1
- GET-Parameter bei Einzelansicht: ?tt_products[backPID]=35&tt_products[product]=4&tt_products[cat]=1&cHash=

Wenn ich die Einzelansicht aufrufe, werden ebenfalls die Marker ###ARTICLE_TITLE###, ###ARTICLE_ITEMNUMBER### und ###ARTICLE_IMAGE1### korrekt mit der ersten Produktvariante gefüllt.

Beim folgenden Marker gilt dies jedoch nicht:
<div id="###ARTICLE_NOTE_ID###">###ARTICLE_NOTE###</div>

Problem:
- Beim Aufruf der Einzelansicht wird der Marker ###ARTICLE_NOTE### durch den Inhalt der PRODUKTbeschreibung (PRODUCT_NOTE) ersetzt.
- Erst wenn eine Variante im Selectmenü gewählt wird, gibt der Marker den richtigen Inhalt aus.

Muss der GET-Parameter noch um die gewünschte (erste) Variante ergänzt werden, oder was kann die Ursache für dieses Verhalten sein?
26-09-14 19:14:43 Korrektur
Franz Holzinger
In der Datei model/class.tx_ttproducts_article_base.php muss diese Änderung gemacht werden:

ungefähr Zeile 260:

$fieldArray['data'] = array('title', 'subtitle', 'itemnumber', 'image', 'weight', 'inStock', 'note', 'note2');

Hier hinten die Felder 'note' und 'note2' dranhängen.
29-09-14 11:50:14 Problem gelöst
Sebastian Klein
Vielen Dank für Ihre Hilfe! Jetzt funktioniert es.
< Zurück zum Forum