Franz Holzinger

Verse of the day

Nichts tut durch Zank oder eitle Ehre; sondern durch Demut achte einer den andern höher denn sich selbst, und ein jeglicher sehe nicht auf das Seine, sondern auch auf das, was des andern ist.
Philipper 2:3-4

© Bible Gateway's Verse of the Day


Autor  
21-06-12 10:44:20 tt_products 2.7.4.2 + Typo3 4.7.1
Matthias Hoppe
Hallo an alle Forummitglieder und Herr Holzinger,

mein Problem ist folgendes:
Ich habe eine Typo3-Installation 4.7.1 mit der Erweiterung tt_products 2.7.4.2. Ich möchte, dass der Produkttitel als altText im Produktbild angezeigt wird. Eigentlich sollte das kein Problem sein. Das Buch "Der Typo3-Webshop" verrät es auf Seite 129 ganz einfach. Aber leider bleibt das alt-Attribut bei mir leer.

So funktioniert es:
altText = irgend ein text

So funktioniert es nicht:
altText = TEXT
altText.data = field:title

Ich habe eine andere Installation von Typo3 4.5.14 mit tt_products 2.7.2 bei der es super funktioniert.

Hier der ausschnitt meiner TS-Setup:
plugin.tt_products = USER
plugin.tt_products {
image {
file.maxW = {$plugin.tt_products.maxW_single}
file.maxH = {$plugin.tt_products.maxH_single}
altText = TEXT
altText.data = field:title
imageLinkWrap = {$plugin.tt_products.clickEnlarge}
imageLinkWrap {
enable = 1
bodyTag = <body bgColor="black" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
wrap = <a href="javascript:close();"> | </a>
width = {$plugin.tt_products.maxW_popup}
height =

JSwindow = 1
JSwindow.newWindow = 1
JSwindow.expand = 0,0
}
}
listImage < .image
}

Vielen Dank für eure Hilfe
25-06-12 09:10:08 image altText
Matthias Hoppe
Benötige Hilfe. Bitte um Antwort. Danke
25-06-12 18:43:13 nicht reproduzierbar
Franz Holzinger
Ich kann den beschriebenen Fehler mit der aktuellen tt_products 2.7.4 und TYPO3 4.7.0 nicht reproduzieren.

10-07-12 09:44:12 erledigt
Matthias Hoppe
Ich verstehe es zwar nicht ganz aber es funktioniert jetzt. Woran es genau lag weiß ich nicht aber wahrscheinlich ein Fehler von mir selber.
< Zurück zum Forum