Franz Holzinger

autor  
16-06-17 14:28:19 Ausgabe der Produkte nur in Englisch?
Jacob Paul
Grüße
Ich versuch nun schon längerdie Ausgabe in Deutsch hinzubekommen. Leider ist es bisher fehlgeschlagen.

Ich nutze Typo 6.2 und tt_products 2.8.19 + die abhängigen Extensions.

[TS-Setup]
page {
includeJS {
tt_products = EXT:addons_tt_products/scripts/tt_products_example.js
}
}
page {
includeCSS {
tt_products = EXT:addons_tt_products/template/tt_products_example.css
}
}
plugin.tt_products.TAXpercentage =19
plugin.tt_products.TAXincluded = 1
plugin.tt_products.alwaysInStock=1
plugin.tt_products.PIDlistDisplay= 33
plugin.tt_products.PIDbasket=35
plugin.tt_products.PIDitemDisplay=34
plugin.tt_products.PIDpayment=36
plugin.tt_products.PIDfinalize=37
plugin.tt_products.PIDagb = 38
plugin.tt_products.payment >
plugin.tt_products.payment {
radio=0
TAXpercentage=19
10.title = Rechnung
20.title = Barzahlung
30.title = Nachnahme
plugin.tt_products.shipping {
TAXpercentage=19
10.title = Versand innerhalb Deutschland
10.price = 4.50
10.TAXincluded=1
10.excludePayment=20, 30
20.title = Selbstabholer
20.price =
20.TAXincluded=1
20.excludePayment=10, 30
30.title = Nachnahme innerhalb Deutschland
30.price = 8.50
30.TAXincluded=1
30.excludePayment=10,20
}
}
[Ende]

[TS-Konstanten]

plugin.tt_products {
file.templateFile = fileadmin/templates/main/tt_products_locallang_xml.html
AGBattachment = fileadmin/templates/main/agb.txt
}
[Ende]

Wie stelle ich die Ausgabe auf Deutsch um?

Danke
16-06-17 17:56:47 Produkte auf Englisch und Deutsch
Franz Holzinger
Die Umstellung der Sprache der Produkte geschieht für TYPO3 über dieses Setup. In diesem Beispiel ist Deutsch die Hauptsprache und Englisch liegt an 3. Stelle mit der uid = 2. Allerdings müssen die Produkte auch in der alternativen Sprache vorliegen und es muss ihnen das Produkt in der Standardsprache zugewiesen worden sein.

# German language, sys_language.uid = 0
[globalVar = GP:L = 0]
config.sys_language_uid = 0
config.language = de
config.locale_all = german

# French language, sys_language.uid = 1
[globalVar = GP:L = 1]
config.sys_language_uid = 1
config.language = fr
config.locale_all = french

# English language, sys_language.uid = 2
[globalVar = GP:L = 2]
config.sys_language_uid = 2
config.language = en
config.locale_all = english

# Italian language, sys_language.uid = 3
[globalVar = GP:L = 3]
config.sys_language_uid = 3
config.language = it
config.locale_all = italian

20-06-17 08:46:22 Deutsch
Jacob Paul
Grüße

vielen Dank für die Hilfe. Aber irgendwie passt es immnoch nicht.
Ich habe den Snippet oben übernommen, aber es ist immernoch auf Englisch.
Bei dieser Seite ist erstmal nur eine Sprache (Deutsch) installiert.

In der tt_products_locallang_xml.html, die ich in den Konstanten festlege habe ich mir mal einen Marker rausgesucht.
###LIST_ITEM_PRICE### wird mit "Price" dargestellt und nicht mit "Preis".
Was aber nun seltsam ist, der Marker ###PRODUCT_NOTE### wird richtig übersetzt. Da steht bei mir Produktbeschreibung, so wie es sein soll in Deutsch.

Hier ein Screenshoot:
http://www.bilder-upload.eu/show.php?file=72f809-1497941257.jpg

Irgendwas stimmt mit den Markern nicht, oder?

Danke

20-06-17 09:34:57 Deutsch
Jacob Paul
Ich muss das mit dem Marker ###PRODUCT_NOTE### zurücknehmen. Das ist ja ein Feld, was ich bei dem Produkt ausgefüllt habe.

Das heißt ich bekomme das nicht in Deutsch gezeigt.
20-06-17 10:53:47 Translation Server
Franz Holzinger
Die Übersetzungen der Sprachdateien befinden sich auf dem TYPO3 Translation Server.

https://translation.typo3.org/de/TYPO3.ext.tt_products/marker/locallang.xlf

Dort sollten fehlende Übersetzungen verifiziert werden. Man kann diese Sprachen über das Languages Tool im TYPO3 Backend herunterladen. Alternativ müsste man das typo3conf/l10n/de/tt_products/marker/ Verzeichnis öffnen und dort die Datei de.locallang.xlf überarbeiten.

Für einige Sprachen gibt es Sprachdateien in der Extension addons_tt_products, die dann allerdings installiert sein muss.

20-06-17 11:44:56 Translation Server
Jacob Paul
Vielen Dank für den Hinweis.

Wenn ich auf der Seite bin
https://translation.typo3.org/export/TYPO3.ext.tt_products/de/marker/locallang.xlf
und auf den Download-Link drücke, bekomme ich leider diese Info.


Unhandled Exception

An unhandled exception was thrown by the application.
20-06-17 12:36:03 de.locallang.xlf
Jacob Paul
Grüße

Ich habe mir nun die "de.locallang.xlf" angesehen auf dem Server. Sie ist vom 20.06.2017 12:24. Also ganz frisch.

Kleiner Schnippsel:
[Datei]
<?xml version='1.0' encoding='utf-8'?>
<xliff version="1.0">
<file source-language="en" datatype="plaintext" original="messages" date="2017-02-17T02:37:01Z" product-name="tt_products" target-language="de">
<header/>
<body>
<trans-unit id="memo_dam_goto" xml:space="preserve" approved="yes">
<source>Go to DAM memo list.</source>
<target state="translated">Gehe zur DAM Merkliste.</target></trans-unit>
<trans-unit id="memo_goto" xml:space="preserve" approved="yes">
<source>Go to the memo list.</source>
<target state="translated">Gehe zur Merkliste.</target></trans-unit>
...
[Datei]

Das ist in alles in deutsch.

Die Frage ist nun, warum er nicht die deutsche Übersetzung zeigt.

20-06-17 12:44:24 TYPO3 Umgebung
Franz Holzinger
Sie müssen diese Übersetzung auf Ihre TYPO3 Umgebung holen. Das habe ich vorhin beschrieben.

Fehler auf dem Translation Server melden Sie direkt unter
https://forge.typo3.org/projects/team-translation-site/issues

20-06-17 12:52:11 de.locallang.xlf
Jacob Paul
Mit Server meinte ich meinen Server. Das heißt doch, das er in meiner Typo3 Umgebung ist, oder?

LG
20-06-17 12:58:30 L Parameter
Jacob Paul

Da ich nur in Deutsch die Seite zeige, habe ich die seite ganz normal aufgerufen:
index.php?id=33 (keine Übersetzung)

Nun habe ich den L Parameter mal genutzt
index.php?id=33&L=0 (wird übersetzt)

Ich muss also den L Parameter nutzen um die Übersetzung zu sehen.


Gibt es eine Möglichkeit ohne L Parameter eine deutsche Überstzung hinzubekommen?


Danke
20-06-17 14:29:34 immer Deutsch
Franz Holzinger
Das muss ins Setup:

config.sys_language_uid = 0
config.language = de
config.locale_all = german

Vorher keine Zeile wie diese:

[globalVar = GP:L = 0]

Denn sonst ist diese TypoScript Condition (Bedingung) nur gültig, wenn der L-Parameter 0 gesetzt ist: "&L=0".
20-06-17 15:33:32 immer Deutsch
Jacob Paul
puh, daran lag es.

Vielen Dank!
< BACK TO FORUM